The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.
Metrics
Affected Vendors & Products
Advisories
No advisories yet.
Fixes
Solution
No solution given by the vendor.
Workaround
No workaround given by the vendor.
References
History
Tue, 03 Nov 2026 05:00:00 +0000
Projects
Sign in to view the affected projects.
Status: PUBLISHED
Assigner: Wordfence
Published:
Updated: 2026-11-03T04:43:09.150Z
Reserved: 2026-11-02T16:35:21.885Z
Link: CVE-2026-120563
No data.
Status : Deferred
Published: 2026-11-03T05:18:33.647
Modified: 2026-11-03T05:18:33.790
Link: CVE-2026-120563
No data.
OpenCVE Enrichment
Updated: 2026-11-03T06:30:09Z
Weaknesses