The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
Metrics
Affected Vendors & Products
Advisories
No advisories yet.
Fixes
Solution
No solution given by the vendor.
Workaround
No workaround given by the vendor.
References
History
Fri, 06 Nov 2026 07:45:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Weaknesses | CWE-200 CWE-285 |
Fri, 06 Nov 2026 06:15:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Description | The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions. | |
| Title | Surfer < 1.8.1.759 - Contributor+ Privilege Escalation via Editor API Key Disclosure | |
| References |
|
Projects
Sign in to view the affected projects.
Status: PUBLISHED
Assigner: WPScan
Published:
Updated: 2026-11-06T06:00:26.032Z
Reserved: 2026-10-28T17:18:28.308Z
Link: CVE-2026-118639
No data.
Status : Received
Published: 2026-11-06T06:16:41.250
Modified: 2026-11-06T06:16:41.250
Link: CVE-2026-118639
No data.
OpenCVE Enrichment
Updated: 2026-11-06T07:30:09Z